Bienvenido(a), Visitante. Por favor, ingresa o regístrate.

Autor Tema: [Ayuda] Rayas en astrofotografía con DSLR  (Leído 180 veces)

Desconectado D_79

  • Astronauta
  • *****
  • Miembro n°: 12794
  • Mensajes: 562
    • Ver Perfil
[Ayuda] Rayas en astrofotografía con DSLR
« en: 13-Jul-21, 23:44 »
Hola a tod@s,

Comparto con vosotros a ver si alguien me puede ayudar a saber qué está pasando y cómo puedo solucionarlo.

La cuestión es qeu cuando obtengo la imagen apilada en PixInsight obtengo un master Light que cuando le hago un ScreenTransferFunction, con toda mi ilusión, me doy cuenta que muchas veces me salen unas rayas desagradables. A veces són más evidentes y otras no tanto o no se ven, pero en la mayoria de ocasiones sí. En el caso concreto que os muestro son fotos tomadas este fins de semana a M31.
Són 229 tomas Light a f/6,3, ISO 800mm y un tiempo de 40 s tomadas con una Canon ESO 7D sin refrigerar ni modificar y un objetivo fotográfico a 200mm. Hice también 81 Darks a f/6,3 ISO 800 y 40 segundos (objetivo a 200mm tapado con la tapa), 64 Bias a f/6,3, ISO 800 y un tiempo de 1/8000. También realicé 40 flats a f/6,3, ISO 800 y esta vez el tiempo necesario fueron 1/2000 y como que alguna vez me había pasado lo de las rayas y me aconsejaron hacer master darks y los hice, 47, mismas condiciones que los flats pero con el objetivo tapado. Los he apilado manualmente siguiendo los consejos de un curso de la universidad Carmen de Michelena dirigido por Leoncio Peiro (el enlace en Youtube es:
list=PLOGlWYzHu8o7U9XLkM_LkR-6yhoM74VV9&index=4 ).

Pues apilo manualmente y obtengo como resultado esta imágen donde os señalo con "flechas" rojas las rayas que se observan. insisto en que la imagen no lleva ningún procesado, tan solo está estirada virtualmente y le he realizado una captura de pantalla.



He hecho unos recortes donde las rayas para ue se vean mejor:

De la parte de arriba...




De la parte de abajo...




Al ver el resultado, he repetido la integración de los Lights pero esta vez con datos drizzle y el resultado se ve menos porque las líneas se ven más estrechas pero siguen ahí.





Antes de hacer todo el calibrado y apilado manual, pasé los lights obtenidos por el blicnk y ya borré una imagen en la que la banda o rayas era gruesa y evidente pero no he observado que estas rayas estuviesen en más tomas (sinó las hubiese quitado).

También debo hacer saberq ue como mi cámara es una 7D y en las Canon antiguas hay un problema con algo de la ubicación de los píxeles al pasarlos a matríz que se refleja en la primera columan y no sé que efectos tenía... tengo activado el RAW_compat tal y como comentan en el foro de PixInsight:

Citar
The RAW module included in the standard PixInsight distribution since core version 1.8.8 uses LibRaw 201910 snapshot. Since this version, LibRaw has changed the way some raw formats are decoded. The changes we are interested in here refer to the coordinates of the visible region of the raw image with respect to the entire (uncropped) raw frame. As you probably know, many (most?) DSLR raw formats define unused areas of the raw frame, which correspond to rows and columns of pixels that are never exposed to light. Obviously, these unused regions are located at the edges of the raw frame, and their dimensions and location depend on the particular formats used by each camera model. Our RAW module provides a preferences option to enable/disable automatic cropping of unused areas, which is enabled by default.

Enlace al foro de PixInsght: https://pixinsight.com/forum/index.php?threads/compatibility-update-raw-module.13667/

Llegados a este punto solo me queda hacer pruebas y ver si dando palos de ciego puedo dar con algo:

Había pensado en hacer correr el script WeightedBatchPreProcessing 2.0, a ver si el script lo hace mejor que yo manualmente.

En caso contrario volver a pasar los Lights por el blinck y también por el SubFrameSelector y ser mucho más estricto en el descarte de imágenes.

Y si tampoco funciona cambiar las ociones del RAW que me vienen por defecto:



y ponerlas como pure Raw y volver a empezar otra vez probando calibraciones y apilados a ver si mejora....

¿Alguien tiene idea de qué me puede estar pasando y/o me puede poner sobre la pista?

Muchas gracias  :'(

Mi blog (fotografía):  Nature Shots

Desconectado Roberto "Akeru" - Cielos Boreales

  • Extraterrestre
  • ******
  • Miembro n°: 3307
  • Mensajes: 1026
    • Ver Perfil
    • Cielos Boreales.
  • Agrupación astronómica: AAMS y Astrohenares
Re:[Ayuda] Rayas en astrofotografía con DSLR
« Respuesta #1 en: 14-Jul-21, 17:58 »
Parece que es el "Canon banding". En el propio PixInsight tienes un script para reducirlo y si buscas ese concepto en Google encontrarás algunos consejos para lidiar con él.
Roberto "Akeru" / www.cielosboreales.com 

Turismo Estelar / Turismo Estelar, hoteles y casas rurales para disfrutar de las estrellas
---------------------------------------------------

Desconectado D_79

  • Astronauta
  • *****
  • Miembro n°: 12794
  • Mensajes: 562
    • Ver Perfil
Re:[Ayuda] Rayas en astrofotografía con DSLR
« Respuesta #2 en: 14-Jul-21, 19:45 »
Parece que es el "Canon banding". En el propio PixInsight tienes un script para reducirlo y si buscas ese concepto en Google encontrarás algunos consejos para lidiar con él.

Gracias por ponerme sobre la pista Roberto!

Sí, ciertamente he puesto en Google "Canon banding" y lo primero que me ha redirigido es a otro foro donde hay una imagen que le pasa lo mismo. Yo pensaba que eso del banding era en toda la imagen pero veo que puede salir en diferentes sitios y no de forma regular.

https://stargazerslounge.com/topic/289890-canon-banding-problem/

Ahora llevo un par de horas con el ordenador procesando el WBPP2.0 a ver que resultado "cocina". Supongo que por lógica me tiene que dar lo mismo que en manual. Me miraré esto del Script y como se usa.

Gracias! :bravo:
Mi blog (fotografía):  Nature Shots

Desconectado D_79

  • Astronauta
  • *****
  • Miembro n°: 12794
  • Mensajes: 562
    • Ver Perfil
Re:[Ayuda] Rayas en astrofotografía con DSLR
« Respuesta #3 en: 16-Jul-21, 22:50 »
Hola,

Os muestro como ha quedado corregida la misma imagen de antes pero después de pasarle en Script Canon Banding de PixInsight. Fue de lo más facil quitarlo, use la vista previa en tiempo real y toquetee levemente los deslizadores porque con los parámetros iniciales ya casi estaba resuelto.



Antes de aplicar el Script, volví a apilar todos los datos pero esta vez usando el script de Weighted Batch Preprocessing (WBPP 2.0), tardó 5 horas en hacer todo el proceso, esta vez automatizado (la anterior era fruto de un apilado manual) y lo curioso del caso es que no mostró ningún tipo de banding. Es decir, a este master light no le tuve que hacer ningún tipo de corrección con el script de Canon Banding ni nada.



Ahora me surge otra duda y es que en la imagen del apilado manual (ambas són capturas de pantalla depués de hacer un estirado virtual con STF) parece que se notan cierta nebulosidades o fragmentos rojizos ya en el master light. En cambio en la que apilé automáticamente no se observa a simple vista, lo que no significa que no tenga.... supongo.

Como no puedo hacer otra cosa para sacarme la duda de encima procesaré ambas imágenes de forma similar a ver si obtengo resultados cercanos o si el apilado manuals marca diferencia o no respecto el nuevo script de apilar WBPP 2.0

¿Qué opináis?

Saludos ;)
Mi blog (fotografía):  Nature Shots

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40